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Welcome to Rodni, a modular animatronic 
animal of your own creation for learning how 
easy it is to enter the world of software 
programming and micro controllers.

During the Rodni workshop you will build your 
own Rodni and learn how to make his heart 
"beat", his head move and also give him sight 
and the ability to interact with you.

The Rodni project is not about learning a 
programming language but about learning how 
easy it is to get quick results using material 
downloaded from the internet and picking up the 
necessary skills as you progress.

Rodni is powered by Arduino. This is an 
inexpensive micro controller, a small computer. 
It uses free software downloaded onto your 
laptop or PC. Once the Arduino has been 
programmed it will run independently of your 
main computer enabling you to create many 
exciting projects. Look at www.instructables.com 
for examples of what is possible.

More details about Rodni and many resources 
can be found at www.lowbot.co.uk

Rodni was created by Philip Lowndes 
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Choose a baseboard, a set of feet, a body and a heart.Assemble as shown.

Now we will load some 

software onto the Arduino.

Open the Arduino programme 

on your computer and select 

File>Examples>Basics>Blink.

© PALowndes 2013



You can now see the Blink programme.
Not important at this stage but it has 3 
parts:

1) A list of variables. Here int led=13;
2) void setup() that includes things that 
the programme should read only once.
3) void loop() that will keep repeating 
while the programme runs.

Notice that some lines of the programme 
have // in front of them. This tells the 
Arduino not to read these lines and they 
are used for making notes in the 
programme to make it easier to 
understand what each part does.
 

Plug the USB lead into the 
Arduino board and into your 
computer.
Go to Tools>Board and select 
your board. It is probably a 
UNO.
Now go to Tools>Serial Port 
and select a USB port.

If you click this icon, the right 
pointing arrow, the programme 
will upload to the Arduino. You 

will see yellow lights flashing as 

the computer talks to the 
Arduino.
Eventually the programme will 
run and an LED will steadily flash 

on the Arduino.
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Let's use this programme to make 
the heart flash.
Find an LED. Note that it has a 
flat above the shortest wire. This 
is IMPORTANT.  It shows the -ve 
side.
Thread the LED through the heart 
and bend it downwards.

What value 
would BRown, 
black, orange, 

gold be?

Now find a 560 ohm resistor. 
These are colour coded green, 
blue, brown, gold. Place it in 
the breadboard. 2 possible 
positions are shown in the 
photograph. The pins in each 
line are connected as shown so 

the electronics must bridge 
them.
We are using the resistor to 
reduce the amount of current 
reaching the LED to prevent it 
from burning out.
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Wire up the heart LED.

Now, let's explore how the 
software is working.
The words in a line following // 
are ignored by the Arduino. These 
are just notes explaining the 
program 

At the top int led = 13 is telling the Arduino that we are using pin 13 and calling it led. 
The void setup() section tells the Arduino things that it only needs to know once. Here it is used to say that pin we called led is 
being used and pinmode OUTPUT tells it that it will send outgoing signals.
Notice the use of {  }. These say that this is a discrete section of the code. The code will not run without them. 

Void loop() is the section that the Arduino loops repeatedly.
Again note the use of {  }
digitalWrite refers to whatever is in the brackets following (  ). Here it is saying to 
switch on the LED. HIGH means on.
delay tells it how long to stay on. In this case for 1000 milliseconds (1 second).
The next digitalWrite is to switch off again. LOW

Note the use of ; after each command. The programme will not run without this.
The words in brown are programming language words. If you enter them correctly the 
computer will colour them brown.
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Now for another challenge.
Can you make the LED flash more 

slowly?

Try altering the numbers for delay and 
then  upload to the Arduino by 

clicking the upload arrow.

Brilliant

Now, you are able make the LED 
blink at a regular frequency.

The challenge now is to make the 
heart beat.

How will you do it?

Try changing the led pin 
number from 13 to 8 in the 

programme. Now upload  -  what 
happens?

The LED no longer flashes. You need to 
move the wire from 13 to 8 on the 

Arduino. Now it will flash. 
You have done your first bit of 

programming - EASY!
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Select a head and a neck piece and three bolts. Assemble the head and neck as shown. Note that the fatter part of the neck attaches to the body and the curved side faces forwards.

At the back of the body there 

is a small black box. This is a 

servo. It contains a small 

motor and some electronics to 

control it. We will use this to 

make Rodni move.

Select some eyes and other parts to complete the head.

The servo has 3 wires. The red 

and the brown are used to 

power the servo. The orange 

one carries the messages that 

we send to the servo to tell it 

when to move.

On some servos these wires 

are red, black and white.
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The servo is very simple to 
connect.
First let's give it some power. 
Run a pin wire from the red 
+ve strip on the breadboard to 
the servo plug socket that the 
red wire comes into. Then run 
a wire from the blue -ve strip 
to the plug where the brown 
wire runs in. It is import to get 
these the correct way round. 
The servo may now move a 
little. Now let's add the 
control wire. Find socket 9 on 
the Arduino and run a pin wire 
from this to the socket on the 
orange wire.

So far so good. Now let's look at 

the software needed to run the 

servo.
This is surprisingly easy to set up.

We will simply copy it from an 
example.
Go to the Arduino programme 
File>Examples>Servo>Sweep and 

open the Sweep programme. This 

will open in a new window.
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This section tells the Arduino 
what pin the servo is on. 

Now  in the void loop() section we 
need to make a couple of 
changes. The programme is telling 
the servo to swing from 0 degrees 
to 180 degrees. However Rodni 
will not allow the servo to rotate 
more than 80 degrees. Change 180 
to 80. Notice that instead of 
saying the position to move the 
servo to it is using a VARIABLE - a 
number that can change. The for 
lines are telling  the ARDUINO to 
add a degree until it reaches 180 
degrees and then to take off a 
degree until it reaches 0 degrees.
Upload the programme and see 
what happens.

This section activates the servo 

software built into Arduino and 
names our servo myservo
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Let's simplify things a bit. Delete 

as shown

Replace the variable (pos) with 

numbers as shown
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Increase the delays to 1000 to 
give the servo time to move.



Try Keeping both numbers the 
same

Try making the numbers Different

Try 40 and 60

Try changing the delays (5000 for 
instance)

Well done. Let's save this 
programme as Rodniservo. 
Then let's celebrate by finishing 

building Rodni. Choose a tail and 

other parts that you want to use 

to customise him.
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Set up the power rails on 
the breadboard



Run a wire from the positive 
bar to one side pin of the 
potentiometer

Run a wire from the 
negative bar to one side pin 
of the potentiometer

Finally run a wire from the 
central pin on the potentiometer 

to the socket A0 on the Arduino.

Carefully push a 
potentiometer into the 
breadboard
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We will now see what happens when we turn the potentiometer 

knob. Once again, it is very easy with Arduino because a basic 

programme has been written for us and can be found in Examples. 

Open File>Examples>01 Basics>ReadAnalogVoltage.

Upload this programme and then click on the button with a 

magnifying glass at the top right of the window. The computer will 

start talking to the Arduino and will show the voltage it is reading 

as commanded in Serial.printIn(voltage);

Turn the potentiometer knob and see what happens to the numbers
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Let's simplify this a little. Make changes as shown. Now upload and 

open the serial monitor. You will now see numbers between 0 and 

1023 as you turn the potentiometer knob. The Arduino is receiving 

and reading an external stimulus when you turn the knob The 

software has called a variable sensorValue and is reading numbers 

into this through pin A0
It is then printing the number it reads onto the screen.

Upload this programme and then click on the button with a 

magnifying glass at the top right of the window. The computer will 

start talking to the Arduino and will show the voltage it is reading 

as commanded in Serial.printIn(voltage);

Turn the potentiometer and see what happens to the numbers

Load ReadAnalogVoltage again
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Let's use this now to make Rodni 

come alive. We are going to use 

the variable from the 
potentiometer to control the 
servo

Load the Knob programme.
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This line is mapping the range 0 to 1023 to 0 to 179. (So 

1023 becomes 179). However Rodni can only handle the 

servo turning up to 80 degrees so change 179 to 80.

Now changes in the variable coming from the 

potentiometer will be converted from a range of 1 to 1023 

to a range of 0 to 80 degrees.

SAVE as 
Rodnimove

Turn the 
potentiometer 

knob after 
uploading

© PALowndes 2013



Inside Rodni's 

head there is a 

small electronic 

part called a light 

sensitive resistor. 

In a bright light 

this component 

has a low 

resistance and in 

a dim light it has 

a high resistance. 

We can use this 

to measure the 

light intensity and 

give Rodni 

"sight".

Take 2 wires with sockets at 

one end and pins at the other 

and attach the sockets to the 

wires coming out of Rodni's 

head.

Now find a 10,000 ohm resistor.

Check with the colour code 

chart.
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Insert one wire from the 
light sensitive resistor on 
one side of the resistor

Connect the other wire 
from the light sensitive 
resistor to the +ve (red line) 
bar.

Connect the other side of 
the resistor to the negative.

Finally run a wire from the 
resistor to the socket A0 on the 

Arduino.

Now we will replace the 
potentiometer with a 
resistor and a light 
sensitive resistor
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Resistor

Light sensor

Let's take a look at what we just did.

We are trying to measure the amount of light hitting the light sensitive resistor. 

This light affects its resistance.
The problem that we have to overcome is that the Arduino cannot measure 

resistance directly. However it can measure voltage. If electricity was water, 

voltage would be the water pressure. 

Our circuits are running on 5 volts so there is 5 volts difference between +ve and -

ve. (A) and (B). We need not worry about the detail here but if we have 2 resistors, 

the 10,000 ohm one and the light sensitive resistor we can measure the difference 

in voltage between them.
The sockets beginning with A on the Arduino are analog pins. The other ones are 

digital pins. Digital pins only read and write on and off. Analog pins can tell the 

difference between different levels of voltage.

The Arduino converts the voltage to a number between 0 and 1023.

We will try this out next to see how it works.

Don't worry too much about this 
page. You can miss it out if you like but you 
might like to know a little about what we 

are trying to do.
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Let's simplify this a little. Make changes as shown. Now upload and 

open the serial monitor. You will now see numbers between 0 and 

1023 as you turn the potentiometer knob. The Arduino is receiving 

and reading an external stimulus when you turn the knob The 

software has called a variable sensorValue and is reading numbers 

into this through pin A0
It is then printing the number it reads onto the screen.

Upload this programme and then click on the button with a 

magnifying glass at the top right of the window. The computer will 

start talking to the Arduino and will show the voltage it is reading 

as commanded in Serial.printIn(voltage);

Shade Rodni's nose and see what happens to the numbers. Note the bright and dark numbers

Load ReadAnalogVoltage again
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Reload the programme you saved as Rodnisee. 

Alternatively open Knob again.

Try varying the delay time and also the map numbers. 

Experiment.
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When we measured the variable coming front the 

light sensor we got a narrower ranger than 0 to 

1023. Substitute the numbers that you recorded 

and then upload.  

Try varying the delay time and also the map numbers. 

Experiment.
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All the commands and how to use them can be found on 

the arduino.cc website



Challenge

At the moment you have Rodni reacting 
to different light levels. It would be 
better for interactivity if he reacted to 
a change in light level rather than the 

absolute level.
How would you do this?

Challenge

How would you make Rodni go to 
sleep when it gets dark?

Tougher Challenge

How would you make Rodni go to sleep 
when he gets bored?

Challenge

Can you now add his heart beat?
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